Page 1 of 1

Error 339: Component 'comdlg32.ocx' error

PostPosted: Fri May 27, 2011 5:00 am
by EsnAuberon

I think Bullzip PDF printer is great and i've been using it for a while on my other windows xp 32 bit machines. Recently built an HTPC with Windows 7 Pro 64-bit and tried to install and use bullzip. Installation goes fine, i let it install to default program files directory (not x86). WHenver i try to print, i get this message:

An error occurred.

Error 339: Component 'comdlg32.ocx' or one of its dependencies not correctly registered: a file is missing or invalid

Source: GUI

Internal hint: Get the configuration for this PDF generation

I looked online and downloaded comdlg32.ocx and registered it in the system32 folder and the syswow64 folder...still doesn't work.

any idea what's wrong?


Re: Error 339: Component 'comdlg32.ocx' error

PostPosted: Sun Jul 24, 2011 8:21 pm
by jr

Are you using the latest version and have you tried to reinstall the printer?

Re: Error 339: Component 'comdlg32.ocx' error

PostPosted: Wed Nov 13, 2013 12:00 pm
by jr
This error can be caused by missing permissions on the file comdlg32.ocx and mscomctl.ocx in Windows\System32 (Windows\SysWOW64 on 64 bit systems). You should make this file inherit permissions from the parent folder or add read and execute permissions for normal users.

The next version (10.2) will make sure the security is setup correctly.

A thank you for the hint goes to Claus from Germany!